Internet Speed Issues
Incident Report for First American Equipment Finance
Resolved
This is now resolved.
Posted Nov 15, 2024 - 15:52 EST
Monitoring
We are noticing improvements with the internet speeds. We are actively monitoring the situation at this time.
Posted Nov 15, 2024 - 13:58 EST
Investigating
We are aware of issues with some of our apps loading slowly or not at all. We are actively investigating the root cause of this issue.
Posted Nov 15, 2024 - 13:14 EST
This incident affected: FAEF Infrastructure (IT Infrastructure).