Workleep Pingboard - Profiles cannot be updated

Incident Report for First American Equipment Finance

Resolved

On the new Pingboard platform, your “About Me” section is limited to 500 characters. If your current section exceeds this limit, you’ll need to shorten and rewrite it before saving. After updating your text, click on another section of your Pingboard profile—this will activate the Save button (it will turn blue).
Posted Nov 25, 2025 - 11:55 EST

Investigating

We are aware of an issue preventing profile updates from being saved in Pingboard. Our team is actively working with Workleap Support to resolve this and will share updates as soon as they’re available.
Posted Nov 24, 2025 - 11:21 EST
This incident affected: Pingboard.